Начало работы с Ардуино на Mac OS X

Этот документ о том, как подключить Ардуино к компьютеру и прошить его своей первой программой.

 

1 | Возьмите Ардуино и USB-кабель

Данное руководство рассчитано, прежде всего, на платы Arduino UnoArduino DuemilanoveNanoArduino Mega 2560 , или Diecimila. Если вы используете какую-то другую модель Ардуино - лучше обратитесь к соответствующей странице в разделе "Начало работы".

Вам понадобится стандартный USB-кабель (с коннекторами типа А и B): такой кабель обычно используется для подключения принтера. (Для Arduino Nano нужен другой кабель - с разъемами типа A и Mini-B).

 

2 | Скачайте среду разработки Arduino

Последнюю версию можно найти здесь.

По завершению закачки дважды щелкните по скачанному .zip-архиву и распакуйте программу.

3 | Установите программное обеспечение

Скопируйте папку с распакованной программой в директорию Applications (или в любую другую папку на вашем компьютере). Если вы используете Arduino Uno или Mega 2560, то на данном этапе установка программного обеспечения завершена - можете переходить к следующему шагу.

Если у вас более старая модель Ардуино (Duemilanove, Diecimila, или любая другая плата с микросхемой-преобразователем FTDI), то вам нужно будет установить драйвер для этой микросхемы. На плате Ардуино чип FTDI обычно выглядит так:

Для этого необходимо скачать последнюю версию драйвера с сайта FTDI, распаковать архив и следовать инструкциям инсталлятора. После установки драйвера необходимо будет перезагрузить компьютер.

4 | Подключите устройство

При подключении устройства к компьютеру следует иметь ввиду следующее. Arduino Uno, Mega, Duemilanove и Arduino Nano автоматически распознают источник питания - будь это USB либо внешний источник питания. Если же вы используете Arduino Diecimila, то перед подключением к компьютеру необходимо убедиться, что устройство настроено на питание от USB. Источник питания на этой плате выбирается джампером (небольшая пластмассовая деталь, позволяющая замкнуть между собой только два вывода из трех), подключающего цепь питания платы либо к USB, либо к разъему питания. Перед подключением Ардуино к компьютеру убедитесь, что джампер стоит на двух выводах, которые расположены ближе к USB-разъему.

С помощью USB-кабеля подключите Ардуино к компьютеру. При этом должен загореться зеленый светодиод питания (отмеченный на плате как PWR).

Если вы используете Arduino Uno или Arduino Mega 2560, то при подключении появится диалоговое окно с сообщением об обнаружении нового сетевого интерфейса. Кликните "Network Preferences...", дождитесь появления окна и нажмите кнопку "Apply". Arduino Uno или Mega 2560 появится в системе под статусом "Not Configured" - это нормально, устройство будет работать корректно. Выйдите из системных настроек.

5 | Запустите среду разработки Arduino

Дважды щелкните по иконке среды Arduino. (Примечание: если язык интерфейса установлен неправильно - его можно изменить в окне настроек. Для получения дополнительной информации см. раздел Среда разработки).

6 | Откройте код тестовой программы

Откройте тестовую программу, которая просто моргает светодиодом: File > Examples > 1.Basics > Blink.

7 | Выберите в меню свою модель Ардуино

Теперь в меню Tools > Board необходимо выбрать пункт меню, соответствующий вашей модели Ардуино.

Выбор Arduino Uno

Для моделей Duemilanove с контроллером ATmega328 (модель микроконтроллера написана сверху на микросхеме) выбирайте пункт "Arduino Duemilanove" или "Nano w/ ATmega328". В первых моделях Arduino использовался контроллер ATmega168; для таких моделей необходимо выбрать пункт "Arduino Diecimila, Duemilanove, or Nano w/ ATmega168". (Подробнее о пунктах меню и выборе моделей читайте на странице о среде разработки.)

8 | Выберите последовательный порт

В меню Tools > Serial Port выберите последовательное устройство, которое соответствует подключенному Ардуино. Как правило, на Mac-системах это будет строка /dev/tty.usbmodem (для Arduino Uno или Mega 2560), либо строка /dev/tty.usbserial (для других моделей).

Выбор моделей Uno, Mega2560 или новее. 

Выбор старых моделей на базе чипа FTDI

9 | Прошейте программу

После всех выполненных действий просто нажмите кнопку "Upload" в среде программирования Ардуино. Подождите несколько секунд - вы увидите мерцание светодиодов RX и TX на плате. Если процесс прошивки прошел успешно - в строке состояния появится сообщение "Done uploading". (Примечание: для прошивки Arduino Mini, NG или другой платы, за мгновение до нажатия кнопки "Upload" необходимо нажать кнопку сброса на плате).

Если через пару секунд после прошивки на плате начал мигать оранжевый светодиод (подключенный к выводу 13) - поздравляем! Вы успешно настроили и запустили Ардуино.

Если возникли проблемы - см. советы по устранению неполадок.

Вам также будет интересно взглянуть на:

  • примеры использования различных датчиков и приводов
  • справку по языку Ардуино

Текст данного руководства опубликован под лицензией Creative Commons Attribution-ShareAlike 3.0. Примеры кода, встречающиеся в руководстве, являются свободным контентом.